Increased response times
Incident Report for ClearFacts
Resolved
Our response times have returned to a normal level.
Posted Jul 10, 2023 - 13:54 CEST
Investigating
Our systems are currently experiencing a very high load. You might experience increased response times.
Our development team is working on this with the highest priority.
Posted Jul 10, 2023 - 11:57 CEST
This incident affected: Webserver.