Unexpected downtime due to database overload
Incident Report for ClearFacts
Resolved
After some digging, have identified the root cause. The increased database load was due to a single component that issued several unoptimised queries in bulk. We have already rolled out an hot-fix with an optimised version of the query and we will work on improving the bulk operation in a future release.

Needless to say that we will keep monitoring our systems in the following hours.
Posted May 04, 2020 - 12:28 CEST
Update
We are continuing to monitor for any further issues.
Posted May 04, 2020 - 11:13 CEST
Monitoring
The past half hour, several of our customers experienced partial or full downtime of our platform. This was due to an overloaded read replica of one of our databases.

At this point normal operation has been resumed. We are still looking into the root cause of the issue.
We appreciate your understanding and are working hard to prevent this from happening in the future.
Posted May 04, 2020 - 11:12 CEST
This incident affected: Webserver.