Issue with the Exact Online integration using their (REST) API for requesting financial period statuses (open/closed) for journals
Incident Report for ClearFacts
Resolved
We have been able to take the necessary correction measures. After a synchronisation has run for the impacted dossiers tonight, this incident will be resolved.
Posted Jul 23, 2021 - 13:44 CEST
Monitoring
Last night, Exact Online fixed the bug in the API that closed all financial periods. We have run some tests and reactivated all connectors. We will however need today to monitor the situation and reopen all financial periods in a controlled way.
Posted Jul 23, 2021 - 10:08 CEST
Identified
In short: EOL communication temporarily shut down due to a bug following their latest release. Consequence: For lots of customers no financial periods will be available in ClearFacts for processing invoices.
----------------
In long: The REST API JournalStatusList returns (order of magnitudes) duplicated and erroneous data. For all journal types, all financial periods are listed with status 'closed' (1=Afgesloten), and this information is duplicated in the response.

This issue is inflicted by the Exact Online release of 20210722 and has several consequences for our ClearFacts/EOL customers. The communication link with Exact Online has been very slow since, because too much requests need to be launched in order to sync the accounting information. On top op that, the false information about the journal statuses has caused future financial periods for the [ClearFacts journals] to be automatically closed, to be in sync with EOL. This is the root cause for the fact that users cannot select active financial periods whilst processing invoices.

For these combined reasons we decided to temporarily shut down our link with Exact Online until further notice. After they will have fixed this bug, we will still have some operational cleaning work to do, to reopen all erroneously closed financial periods.

We are very sorry for this inconvenience, and will keep you informed on the next steps.
Posted Jul 22, 2021 - 14:58 CEST
This incident affected: Webserver.